Home  >  Forum  >  Android
Post New Query

Android requires compiler compliance level 5.0 or 6.0. Found '1.8' instead.


joined on
March 23,2013
Asked on October 10,2015
I am a newbie for Android and I have created a project in Android using Eclipse IDE. But something goes wrong can anybody fix it?

Android requires compiler compliance level 5.0 or 6.0. Found '1.8' instead. Please use Android Tools > Fix Project Properties

I am using Windows 7, Eclipse Luna IDE and JDK 8.
joined on
March 10,2015
Replied on October 10,2015

This is not problem of your Windows and Eclipse. The problem is created by the Java compiler, to fix it you may do

1- Right-click on your project and select "Android Tools -> Fix Project Properties"

2- Right-click on your project and select "Properties -> Java Compiler", check "Enable project specific settings" and select 1.5 or 1.6 from "Compiler compliance settings" select box

Write Answer









Copyright ©2017 concretepage.com, all rights reserved |Privacy Policy | Contact Us