Home  >  Forum  >  Android
Post New Query

generate-sources failed:Invalid SDK: Platform/API level not available.


joined on
March 27,2014
Asked on November 01,2014
Hi All,
I am trying to build android project using Maven.
Need help to resolve the below issue.

[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal com.jayway.maven.plugins.android.generation2:andr
oid-maven-plugin:3.9.0-rc.1:generate-sources (default-generate-sources) on proje
ct android: Execution default-generate-sources of goal com.jayway.maven.plugins.
android.generation2:android-maven-plugin:3.9.0-rc.1:generate-sources failed: Inv
alid SDK: Platform/API level 19 not available. This command should give you all
you need:
joined on
March 14,2013
Replied on November 01,2014

1. Go to user-home/android-sdks/tools and check for source.properties file.

2. Check the Platform.MinPlatformToolsRev line at the bottom. That number  should be provided to

<sdk>
          <platform>20</platform>
 </sdk>

in pom.xml

Write Answer








Copyright ©2017 concretepage.com, all rights reserved |Privacy Policy | Contact Us